Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M10-15

Υπολογισμός Αθροίσματος ( Παράδειγμα 10 )

Να γραφεί αλγόριθμος ο οποίος θα υπολογίζει και εμφανίζει το άθροισμα των ακεραίων αριθμών από το 1 μέχρι το 7.

 

Dim lights

 

 

Εργαστηριακή Άσκηση

Αντιγράψτε και επικολλήστε το πρόγραμμα στον συντάκτη του προγραμματιστικού περιβάλλοντος.

Στη συνέχεια επιλέξτε Εκτέλεση ή Βηματική Εκτέλεση.

 

 

ΠΡΟΓΡΑΜΜΑ  Παράδειγμα_10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: s, i
 
ΑΡΧΗ
s <-- 0
i <-- 1
ΟΣΟ i <= 7 ΕΠΑΝΑΛΑΒΕ
s <-- s + i
i <-- i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ s
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΠΡΟΓΡΑΜΜΑ  Παράδειγμα_10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: s, i
 
ΑΡΧΗ
 
 
s <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
s <-- s + i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ s
 
 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Κάνετε αντιγραφή κι επικόλληση του κώδικα στον online compiler της Python

https://www.tutorialspoint.com/execute_python_online.php

 

# Python

sum = 0

i = 1

while i <= 7:

    sum = sum + i

    i = i+1    

print('The sum is', sum)

 

sideBar



You are here: ΛΥΚΕΙΟ